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( References
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MultiSpec Tutorials (engineering.purdue.edu/~biehl/MultiSpec/tutorials.html)

( Objective
The objective of these exercises is to allow one to gain some experience using a freeware package named MultiSpec.  Specifically you will display multispectral and thematic images, run unsupervised classifications (ISODATA), run supervised classifications and display the results plus obtain experience with some utility functions.

Background.  MultiSpec is a multispectral image data analysis software application that was developed at Purdue University. It is intended to provide a fast, easy-to-use means for analysis of multispectral and hyperspectral image data, such as that from Landsat, SPOT, MODIS, Quickbird, IKONOS, Airborne Visible-Infrared Imaging Spectrometer (AVIRIS), EO-1 Hyperion, ASTER and many others. The primary purpose for the system was to make new, otherwise complex analysis tools available to the general Earth science community. It has also found use in displaying and analyzing many other types of non-space related digital imagery, such as medical image data and in K-12 and university level educational activities.

MultiSpec has been implemented for both the Apple Macintosh and Microsoft Windows operating systems (OS).  Although copyrighted, MultiSpec with its documentation is distributed without charge. The Macintosh and Windows versions and documentation on its use are available from the web at: engineering.purdue.edu/~biehl/MultiSpec/.
MultiSpec is copyrighted (1991-2018) by Purdue Research Foundation, West Lafayette, Indiana.

Exercise List
  1:  Display and Inspect Image Data

  2:  Unsupervised Classification

  3:  Supervised Classification – Select Training Fields

  4:  Classification 
  5:  View Classification Map

  6:  Classification Probability Map

  7:  Combine Separate Image Files into a Single Multispectral Image File

  8:  Overlay Shape Files on Image Window

  9:  Create Vegetation Index (NDVI) Images

10:  Image Enhancement 
Others at: engineering.purdue.edu/~biehl/MultiSpec/tutorials.html
11:  Selecting Areas and the Coordinate View (See Tutorial 7 on MultiSpec web site)
12:  Read HDF Formatted Image Files (See Tutorial 9 on MultiSpec web site)
Other Remarks

There are many other operations that one can do with MultiSpec including several Reformatting processes.  See the MultiSpec Introduction at the MultiSpec web site for more information. The MultiSpec web site is: engineering.purdue.edu/~biehl/MultiSpec/.

Most of the exercises included above are available as tutorials at the MultiSpec web site: engineering.purdue.edu/~biehl/MultiSpec/tutorials.html. The image files that are used in the tutorials are available for download from the web site.

An online version of MultiSpec is available at: mygeohub.org/resources/multispec.

Or contact Larry Biehl at biehl@purdue.edu with questions.

( Exercise 1:
Display and Inspection of Image Data

Requirements:  MultiSpec application and image titled:
                               “S2B_20180515_10m_4bands_majes_area.tif”.
In this exercise, we will display Sentinel 2B image of an area south of Majes, Peru and view the data in several ways using MultiSpec.

1.1
Start MultiSpec using the icon on the desktop or from MultiSpec in the Startup Menu.

1.2
From the File menu choose Open Image. . ..  A dialog box will open to allow one to select the data file one wishes to use.

1.3
Select S2B_20180515_10m_4bands_majes_area.tif in the Exercise1 folder and Open, or simply double-click on 
S2B_20180515_10m_4bands_majes_area.tif.
This is a segment (625 lines x 800 columns of pixels) of a 4-channel image of the irrigated area south of Majes collected on May 15, 2018. Next a dialog box will appear to allow one to choose among various options for the image display.
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Note that by default, the area designated for display is the whole scene and the 3-Channel Color Display Type is selected. The default settings call for the Red screen color to be derived from band 4, Green from band 3 and Blue from band 2. These particular choices will cause the screen image to be in a 3-color format approximating Color Infrared film. 


Select OK.
1.4
This step may not occur for all situations.  If the data histogram has not previously been calculated and stored (in a .sta file), another dialog box will be presented allowing the choice of regions to be histogrammed, so that the channel data values can be properly assigned to screen colors. The default options built into this dialog box are satisfactory, so


Select OK to begin the histogramming.

After the histograms of all of the channels have been computed, the information will be saved to a file named “S2B_20180515_10m_4bands_majes_area.sta” so that they will not have to be re-computed when needed again.

[Note that if a .sta file already exists with the default name, a dialog box will be presented allowing you to overwrite the existing .sta file or save to a different location.]

1.5
The image of the data will now appear.  Notice that just above the image window in the toolbar there are two small boxes with large and small “mountains”. These are image zooming buttons allowing one to zoom in (large mountain) or out (small mountain) from the current image scale. Just to the left of the image zooming buttons is another button which shows X 1 in grayed form. This button allows one to go to X1 magnification directly. The current zoom magnification is displayed along the bottom of the MultiSpec application window in the box labeled “Zoom=”.

Some other options are to hold the ‘Ctrl’ key down while zooming to change the zoom step factor to 0.1 instead of 1. In other words, the zoom factor will change from 1.0 to 1.1 to 1.2 etc. instead of 1, 2, 3, etc. (Note that one uses the ‘Option’ key on the Macintosh version to do this.)

One can make a selection within the image by left click-hold in the image window, drag to select a rectangle, and then releasing the left mouse button. If a selected area exists in the image, any zooming will be centered on the selected area if possible. Clear selection using the “Delete” key.

1.6
One can try different channel combination to go with the red, green and blue screen colors to see if different features in the image are enhanced. From the Processor menu, select Display Image… to bring up the display dialog box and select channel 3 for the red screen color, channel 2 for the green screen color and channel 1 for the blue screen color. This set of choices will cause the screen image to represent a natural color image. 


Try other combinations. 

1.7
Next one can view a side-by-side channel display for data quality inspection.  From the Processor menu, select Display Image… to bring up the display dialog box. Then select Display Type “Side-by-Side Channels”, and select OK to display all four channels in the image side by side.
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The above image window will be displayed (after zooming out) which shows three of the four channels displayed side-by-side that represent the transition from the visible to near infrared wavelength regions. Note that the vegetation areas in channel 4 are brighter than the same areas in channel 3.


The side-by-side channel display is a good way to verify that the channels are registered correctly. In other words, the same location in the image is at the same pixel location in all channels. To do this, select an area in one channel near a field intersection. This same selected area will be drawn in all of the channels. One can then verify that the selected area is at the same location in each channel.


Redisplay the 3-channel image with channels 4, 3 and 2 as Red, Green and Blue. 

1.8
Coordinate View. One can also display a “coordinate view” along the top of the image to present the cursor (mouse) location and selected areas in the image. To do this, select Coordinate View from the View menu. The coordinate view is open automatically if map information exists in the image file.
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If map coordinate information exists for the image, one can display the coordinates as map units. Use the popup menu on the left side of the coordinate view to select the map units.  The area of the selection can be displayed as the number of pixels or in units of acres, hectares, etc using the popup button to the left of “Scale”.  The scale of the image will also be displayed.
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1.9
The 1-Channel Grayscale display type is useful to view the image data one channel at a time. Use the right and left arrow keys to go to the next or previous channel respectively
1.10
The 1-channel Thematic display type is useful to display "product" type images such as MODIS NDVI or any of the other many MODIS products. 
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The data values are grouped into the desired number of levels and a legend is displayed to the left of the image indicating which palette colors are associated with each range of data. (See illustration below.) One can also enter a factor to multiply the data values displayed in the legend by to reflect the actual measurement unit. Sometimes the data value may be the measurement value times 100 or 1000. One can use the Min/Max User Specified dialog box item to set the min and max values for the range of data to be displayed. Black is the default color for data values less than the minimum and white is the default color for values greater than the maximum. A Gaussian stretch is used for this example to distribute the bins across the data range. (Note: This feature can be considered as a supervised 1-channel levels classifier.)
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One can use the Reformat - Change Image File Format processor to create thematic images based on what is displayed in the image window.

One can use right and left arrow keys to go to the next or previous channel (respectively).
This page left blank intentionally
( Exercise 2:
Unsupervised Classification (Cluster Analysis)

Requirements:  MultiSpec application and image titled 
                                                              “S2B_20180515_10m_4bands_majes_area.tif”.
Two Clustering algorithms are available in MultiSpec. They are useful in grouping similar pixels in the image into clusters or categories. One algorithm implemented is a simple one-pass type. The second is an iterative type called ISODATA. We will use the ISODATA algorithm for this exercise. 

To start this exercise, be sure that the “S2B_20180515_10m_4bands_majes_area.tif” image that was used in exercise 1 is open. Also clear any selections in the image window by striking the “Delete Key”

A cluster analysis will be run using the image file represented by the active (top-most) multispectral image window.

2.1
From the Processor menu, select Cluster… to bring up the cluster specifications dialog box.  Select “Do Not Save” in the Cluster Stats: popup menu. Select “Cluster mask file” and select “Image window overlay” under the “Write Cluster Report/Map To” group.
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This will cause a cluster map to be created as a thematic image disk file and display an overlay on the multispectral image window.

2.2
Then select “ISODATA…” This will cause the ISODATA Specifications dialog box to be displayed. Use 10 for the number of clusters, 99 for the convergence percentage and set the line and column intervals to 1 (if needed). Also verify that all lines and columns will be used for the ‘Area to Cluster’, not a subset, and then select OK.
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2.3
You are now back to the Cluster Specifications dialog box.  Select OK to close this dialog box and start the clustering operation.


You will be prompted to enter a name for the cluster map disk file and where to save the file. Just use the defaults by selecting OK in the Save Cluster Map dialog box.


A cluster map will now be created with around 10 classes in an unsupervised manner. You will notice the colors change in the image window as the pixels are sorted into cluster classes during each iteration. After the final iteration, a thematic image file with a map of the cluster classes will be saved to disk. 

The text output for the cluster operation will be at the end of text output window. The information includes the mean values for each of the channels for each cluster for both the initial condition and the ending condition. If the map information is available for the image, the final area for each cluster is listed in the units specified in the coordinate view for the image window.

Usually the convergence is set for a little less than 100 so that the process does not take too long to complete.  One can use 100 in this example so that you have a chance to watch the pixels change cluster classes which illustrates the nature of the ISODATA algorithm; the process should take around 30 seconds.

[image: image33.png]Define Class and/or Field Description

Eter Class Name:
Cover 4]
Nurmber train pielsinclass: 418
Eter ield dentfir:

Field 1

Nurber pixek: 418

Areaype
© Training Field Loncel
TestField
0K





The cluster map overlay on the multispectral image window will look similar to the following.


You can turn the overlay on and off by using the “Red O” popup menu button in the toolbar to the right of the “small mountain” zoom button.

2.4
Now open the cluster map thematic image file. This will be the same image as is shown in the overlay above but you will have more control over the cluster classes.
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From the File menu, select Open Image… to bring up the open image dialog box. You may have to change the “Files of type” popup to All Files or Thematic Files.  Then select “S2B_20180515_10m_4bands_majes_area_clMask.tif” and then select OK. One may need to select “Thematic” for the Files of Type popup menu. 


The Thematic Display Specifications dialog box to the right will be displayed. 


The default settings are fine; select “OK” in the Display Thematic Image dialog box.  This opens a thematic image window. 

2.5
The cluster class legend is on the left in the thematic image window below. 
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Compare the Cluster map with the original image window. Note clusters that represent different densities of vegetation and colors of bare ground. 

There are several things one can do to evaluate the image. One can move the cursor over a color chip, hold the shift key down (cursor will change to an open eye) and click the left mouse button down and up to cause the colors for that class to blink off and on (alternate between white and the color). If one holds down both the shift and ctrl keys and then click the left mouse button down and up, then all of the other classes will blink off and on. These procedures are helpful in understanding the extent of the classes in the image.

One can also change the class color by double clicking on the color chip.

One can change the cluster class names by double clicking on the name to the right of the color chip. The list of interpreted cluster names that I come up with are: A couple of bare ground cover classes outside of the irrigated area, vegetated areas with different levels of ground cover, some soil classes within the irrigated area, and an unknown area of just a few pixels.

2.6
One can also group the cluster classes together in information groups by selecting Classes/Groups in the popup menu above the legend. Then drag the cluster classes into similar information group categories. Again one can double click on the group name to change the name. For example one could change the appearance of the thematic image to represent Bare Soil, Sparse Veg/Soil and Vegetation informational classes.  The popup in the legend allows one to display the original cluster (spectral) classes.
2.7
Note that this Sentinel image has many more than 8 classes. One can run the cluster processor with 20 or 30 clusters to obtain a finer differentiation of the classes in the scene.

( Exercise 3:  Supervised Classification - Select Training Areas
Requirements:  MultiSpec application and image titled 
                                                              “S2B_20180515_10m_4bands_majes_area.tif”. 
One can also do a supervised classification by selecting training areas for specified classes from known areas. 
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3.1
Do this step only if a project window is open. From the Window menu, select Project, and then double click in the upper left to close the current project and project window. One may have been created during the cluster analysis. 

3.2
Now one will select training fields. 


From the Processor menu select Statistics and select OK in the Set Project Options dialog box. (The default settings for this exercise are satisfactory.)

A new window labeled Project will appear to the right of the screen that will be used in a moment. To select training fields for each class, one must simply "drag" a rectangular area on the image (or, with polygon option selected, click on the corners of the desired polygon), and then "Add that field to the list." Thus,
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Drag from the upper left corner to the lower right corner of the Tree training field in the image window. If upon inspection, one does not like the exact boundaries resulting, one may immediately repeat the process. 


Caution: A mistake that is made many times is to select training areas very near edges of a field. One should stay away from the edges by a couple of pixels to reduce the chance of edge affects.

Note in the Project dialog box, that the coordinates (row and column numbers) of the upper left corner and the lower right corner of the selected area appear in box near bottom. Now,
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3.3
Select the Add to list button. A dialog box will appear to allow one to name the class and give the field a special designation, as desired. Thus, Type Cover A (or the actual name of the land cover if known) into the Class Name box and then select OK. 


Note that one can designate the selected area as a training or test area.

3.4
Since there is to be only one training field for this class, we are ready to select the training for the second training class. Thus next,


Drag across the second training field in the Image Window shown below for Cover B.


Select the Add to list button in the Project window.


Select the training areas for the rest of the seven classes –Cover C, D, E, F, and G.
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The Project Window can have four different modes – the Select training field mode, the Class list mode, the Field list mode and the Coordinate list mode. The modes are controlled by four buttons just above the list box at the bottom of the Project Window. The “>Select” button causes the Project window to be in the select mode. The “>Classes” button causes the Project classes to be displayed. The “>Fields” button causes the fields for the selected class to be displayed. The “>Coord.” button causes the coordinates for the selected field to be displayed.


One can delete a class by selecting the class in the class list and then selecting “Cut Class” in the Edit menu. One can also do the same for deleting a specific field.


One can also use polygonal type fields to define training classes. To do this, select the “Polygon Enter” checkbox in the Project Window when in Select mode. Click in the image window to define each corner of the polygon. Double click on the last point. To turn the polygon type selection off, just select the “Polygon Enter” checkbox to deselect it.


Note that the clustering step described in Exercise 2 can be useful in the classifier training step in determining how many classes might be separable in a given data set and where to define training areas such that the spectral characteristics of the pixels are similar.

This page left blank intentionally
( Exercise 4: Classification

4.1
From the Processor menu select Classify…. In the Set Classification Specifications dialog box which appears, note that the default procedure (or algorithm) is Maximum Likelihood. Several choices are available but we will use the default for now. Select the √ near Image Selection under Classify to de-select it since, during this pass, it is desired to classify only the training fields in order to obtain an initial estimate of the quality of the class definition and training. 
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Note that under Write classification results to: One can also select the Disk File button causing a disk file version of the results to be written. Since we have no need for this file in this case, leave this button unselected.

Since the other default options are satisfactory, select OK and then Update to the "Update Project Statistics" dialog box to begin the classification. 

The classification will be complete momentarily.

4.2
From the Window menu select Text Output, to bring the text window forward and make it active, since it contains the classification results. The “TRAINING CLASS PERFORMANCE (Resubstitution Method)” table tabulates how the pixels of each field and class were classified. See example table below. There should be nearly 100% accuracy on the training fields. If the Reference Accuracy is particularly low (say less than 50%) for a class, then the training pixels for that class should be reexamined and new training pixels selected.
Classification of Training Fields

    TRAINING CLASS PERFORMANCE (Resubstitution Method)

    Project                
Reference

        Number of Samples in Class

     Class          
Class 
Accuracy+
Number  
      1
      2
      3
      4
      5
      6
      7

     Name           
Number
   (%)   
Samples 
Cover A
Cover B
Cover C
Cover D
Cover E
Cover F
Cover G

    Cover A          
   1 
   
  99.8  
    418 
    417
      1
      0
      0
      0
      0
      0

    Cover B          
   2 
  
  91.9  
    594 
      0
    546
      0
      0
      0
     48
      0

    Cover C          
   3 
  
  98.6  
    140 
      0
      0
    138
      0
      0
      0
      2

    Cover D          
   4 
  
100.0  
    140 
      0
      0
      0
    140
      0
      0
      0

    Cover E          
   5 
  
100.0  
     56 
      0
      0
      0
      0
     56
      0
      0

    Cover F          
   6 
 
100.0  
     54 
      0
      0
      0
      0
      0
     54
      0

    Cover G          
   7 
  
100.0  
     36 
      0
      0
      0
      0
      0
      0
     36

                     TOTAL


           
 1438 
    417
    547
    138
    140
     56
    102
     38

                  Reliability Accuracy (%)*


 100.0
   99.8
  100.0
  100.0
  100.0
   52.9
   94.7

       OVERALL CLASS PERFORMANCE (1387 / 1438 ) =  96.5%

       Kappa Statistic (X100) =  95.2%. Kappa Variance = 0.000044.

       + (100 - percent omission error); also called producer's accuracy.

       * (100 - percent commission error); also called user's accuracy.

One can try other classifier procedures to compare training class performance results. Remember though that training class performance is a biased estimate of accuracy. Independent test areas will be a better estimate of classification accuracy.
4.3
Assuming satisfactory results, we are ready to classify the whole area.  From the Processor menu choose Classify…  

- Under Areas to Classify de-select Training (resubstitution) by selecting the √ by it, and,


- Select Image selection. Make sure that the entire area of the image is to be classified (lines 1-625 and columns 1-800). Select the square button, if activated, to the left of lines and columns, to force all lines and columns in the image to be used.


- Also select Disk File under Write classification results to: so that a disk file for later use will be created. 


- One can also select Image Window Overlay to cause the classification to be displayed as an overlay on the multispectral image window if you wish to. 


- Also select the Create Probability Results File checkbox so that a classification probability map will be saved to a disk file.


- Then select OK. 


- Select Save in the dialog box that follows regarding a file name for the results. We will use the default name and location for the output classification file and for the probability map file.

As soon as the classification is complete, one will see a summary of the results displayed in the text window.

4.4
You save the project using the File–>Save Project menu item. You will be presented with a dialog box to enter the name (or use the default name). The training and test areas that you selected will be saved. You can open this file up at a later time to continue your analyses.

( Exercise 5:  View Classification Map.
5.1
Now open the classified image named “S2B_20180515_10m_4bands_majes_area_cl.tif”. It should appear similar to the image below. This is a Thematic type image.
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5.2
After displaying the classified image “S2B_20180515_10m_4bands_majes_area_cl.tif”, from the Project menu, select Add as Associated Image to cause the training field outlines to be drawn on the image. You can change the field outline color to black using the Processor->Statistics… menu item and selecting “Black” in the Color popup under the “Outline selected areas:” group.

There are some things that one can do to evaluate the results. One is to move the cursor over a color chip, hold the shift key down (cursor will change to an open eye) and click the left mouse button down and up to cause the colors for that class to blink off and on (alternate between white and the color). If one holds down both the shift and ctrl keys and then clicks the left mouse button down and up, then all of the other classes will blink off and on. These procedures are helpful in understanding the extent of the classes in the image and to determine where classification errors may be. One may need to change training fields or add other classes if there appears to be confusion between the categories that you wish to identify.

One can also change the class color by double clicking on the color chip as was done in the cluster section.

This page left blank intentionally
( Exercise 6:  Classification Probability Map. 

One can view the classification probability map to evaluate which portions of the image have lower and higher probabilities of being classified correctly. There may be other classes in the image that our training fields do not adequately represent.

6.1
Open the probability map named “S2B_20180515_10m_4bands_majes_area_clProb.tif”. Then from the Project menu, select Add as Associated Image to cause the training field outlines to be drawn on the image. It should appear similar to the image below. This is a Thematic type image.
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Yellow to red colors represent a high probability of being correct. These pixels are very close to our training pixels for the classified class. Dark green to blues represent a low probability of being correct. These pixels are very far from the training pixels for all of the classes. The dark blue areas are an indication that there are more than the seven classes that we selected that can be separated successfully.
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( Exercise 7:  Combine Separate Image Files into a Single Multispectral Image File.

Requirements:  MultiSpec application & images titled “LE7_20000606_Indy_sub_Bn.tif”
One can use the "Logically Linking" capability in MultiSpec to link several image files together to be treated as one image file in an image window and/or create a new image file that incorporates all of the separate images. For example many times one will receive Landsat images from the EROS Center by electronic download that contains one file for each of the 7 (TM), 8 (ETM+), or 10 (LC8) bands. This exercise will illustrate how to do this.

Beginning with the 2013.03.14 version of MultiSpec there is a new approach to combine separate image files which takes fewer steps. The multiple selection (easiest) approach is described in section 7.1. The second single selection approach is described in section 7.2. 

Section 7.3 describes how to create a single image file which includes the selected individual image files.

Please refer to section 7.4 if not all of the images files to be linked are at the same spatial resolution. This may the case for the Landsat thermal bands. Currently though, most of the thermal data files in the Landsat image data sets that are downloaded from the EROS Center have already been re-sampled to the sample spatial resolution as that for the reflective data.

NOTE: One can also link multiple image files together that represent multi-temporal data from the same location, provided that line and column numbers for the given pixel ground locations in the separate image files from each of the times have been made to correspond with each other. 
Additional examples illustrating how to automatically link files in HDF or HDF5 format with ASTER data and files in an older Landsat 7 format called FAST-L7A are in tutorial 5 on the MultiSpec web site at: https://engineering.purdue.edu/~biehl/MultiSpec/tutorials.html.
7.1
Multiple selection approach: For this approach, one selects all of the images to be linked at one time in the Open Image File dialog box before selecting the Open button.
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7.1.1
Select the File->Open Image… menu item. Then select the images to be linked as illustrated in the figure below. 


Notice that when one selects more than one file, the link option menu in the lower left defaults to “Link selected files to new image window”. Then select the Open button. The “Display Multispectral Image” dialog box will be presented to allow one to display the image representing the linked image files. 


NOTE: MultiSpec will order the Landsat image data files in wavelength order. See section 7.2 if one wishes the bands to be ordered in a different way.

7.1.2
One can now run the Display Image, Histogram, List Data, Principal Components, and Reformat processors on the "logically linked" image. One cannot use this "logically linked" image as a base image for a Project (see section 7.3 for the procedure to do this). 

7.1.3 An example of a selection for Landsat 8 data follows. [image: image39.png]




The panchromatic band (number 8) will be ignored since it has a different number of lines and columns than band 1 does.

7.1.4
Additional rules and limitations on “multiple selection” Logically Linking are:

- One can only link image files that are being used in multispectral type image windows.

- Any image files in a multiple selection set which contains a different number of lines and columns than the first selected image will be ignored. A message to this affect will be listed in the output text window. 

-The separate image files may contain a different number of data bytes, a different number of channels and they can be a mixture of band interleaved by line (BIL) and band sequential (BSQ) formats. (Note that band interleaved by sample or pixel (BIS or BIP) formats cannot be used in logically linked image files. One will need to change the BIS formatted file to BIL or BSQ first.)

- Any shape files in a multiple selection will be ignored.

- The limit for the number of files in a multiple selection is 500. 

7.2
Single selection approach: This approach involves selecting the images to be linked one at a time within the Open Image File dialog box. It is useful if one needs to link the image files in a different order than they are listed in the dialog box or in the way that MultiSpec orders the Landsat data files downloaded from the standard EROS Center. (MultiSpec orders the image files in wavelength order.)

7.2.1
Open the first multispectral image as one normally would using the File->Open Image… menu item.  The “Display Multispectral Image” dialog box will be presented to allow one to display the selected image.  One may display the image or just cancel the dialog box.  A blank multispectral image window will continue to be displayed. This will become the “active” image window that represents the first image file that will be used in the next steps.

7.2.2
To link an additional image disk file to the active image window, use the File->Open Image… menu item again. Change popup menu in the lower-left portion of the dialog box displaying “Do not link” to “Link selected file(s) to active image window”. Then select the 2nd image file (such as band 2 illustrated in the figure below) to be linked to the active image window.

As long as Cancel is not selected, the open image dialog box will automatically be displayed to allow the user to link additional image files to the active image window. The title for the open image dialog box will indicate the number of files that will be linked with the selection to be made. Also the name of the image window is prefaced with 'Ln-' where n is the number of files that are linked for that image window.

7.2.3
Select ‘Cancel’ after all desired image files have been linked.  Note that one wants to link them in the order that you want the channels to be treated.  For example, many times Landsat TM data is in the order of bands 1 thru 7.  However, if you would like for the channels to be in wavelength order, then select in order of bands 1, 2, 3, 4, 5, 7, 6 or for this example 1, 2, 3, 4, 5, 7, 6_VCID_1, 6_VCID_2.

7.2.4
After linking the separate disk files together, one can run the Display Image, Histogram, List Data, Principal Components, and Reformat processors on the "logically linked" image. One cannot use this "logically linked" image as a base image for a Project (see section 7.3 for the procedure to do this). 

7.2.5
Additional rules and limitations on Logically Linking are:

- One can only link image files that are being used in multispectral type image windows.

- Image files that can be linked may contain a different number of lines and columns. The resulting linked image will contain the largest number of lines and columns that includes the union of those in the separate image disk files. Also the separate image files may contain a different number of data bytes, a different number of channels and they can be a mixture of band interleaved by line (BIL) and band sequential (BSQ) formats. (Note that band interleaved by sample or pixel (BIS or BIP) formats cannot be used in logically linked image files. One will need to change the BIS formatted file to BIL or BSQ first.)

- All image files will be overlaid by starting with the first line and first column in the disk file. No provision has been provided to overlay the image files using different line and column offsets or by latitude/longitude.
7.3
Combining Files into a Single New File: Use the Reformat->Change Image File Format… menu item to create a new disk file that contains all the channels included in the "logically linked" image files. The default options are usually sufficient but you can change them as desired. If the map projection information is known for the image and included with the input images, the GeoTIFF format is a good Header option to use to keep that information with the new image file.



After selecting “OK”, you will have the opportunity to name the file before it is created or use the default name provided. This new file can then be used as a base image for a project. 
7.4
Handling Differing Spatial Resolutions: The thermal channel for many older Landsat data sets may be at a different spatial sampling than that for the reflective channels.  One cannot link the thermal channels without first creating a new thermal image file that has the same spatial sampling as that for the reflective channels. One can do this with a couple of additional steps using the Processor–>Reformat–>Rectify Image… menu item in MultiSpec. The following steps are specifically for Landsat 7 thermal data. They can be modified for other kinds of images.


- Open band 1 (LE7_20000606_Indy_subset_B1.tif) from the set of multispectral images to be linked using the File–>Open Image… menu item. The “Display Multispectral Image” dialog box will be presented to allow one to display the selected image.  One may display the image or just cancel the dialog box.  A blank multispectral image window will continue to be displayed.  


- Open the first thermal band (LE7_20000606_Indy_subset_B61.tif). 


- Make sure the image window for the thermal channel is the active image window and then select the Processor–>Reformat–>Rectify image… menu item. Select “Reproject” in the Rectification Settings group in the “Set Image Rectification Parameters” dialog box as illustrated in the figure below.  Also verify that “LE7_20000606_Indy_subset_B1.tif” is the reference image.


- Select OK and enter the name for the new rectified thermal image (LE7_20000606_Indy_subset_B61_30m.tif). A new thermal image will be created such that it contains a thermal value that matches the location for each pixel in the reference image using nearest neighbor as the sampling scheme. 


- Close the first thermal image window and open the second thermal band (LE7_20000606_Indy_subset_B62.tif). Follow the same procedure used above to create “LE7_20000606_Indy_subset_B62_30m.tif”.
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( Exercise 8:  Overlay Shape Files on Image Window
Requirements:  MultiSpec application, image titled “S2B_20180515_10m_4bands_majes_area.tif” & Area_Agricola_AQP.shp.

One can open ArcView Shape files (as long as an image window is opened first). A popup menu button will appear in the lower left of the Macintosh Image Window to allow one to turn the display of the shape file overlay(s) on and off. The popup menu button for the Windows version is next to the zoom buttons in the toolbar. The shape file will only be added to the active image window. 

The S2B_20180515_10m_4bands_majes_area.tif image has been provided with a shape file in the Shape Files folder to allow one to practice working with a shape file.
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8.1
Display the S2B_20180515_10m_4bands_majes_area.tif image file in a multispectral image window using the File–>Open Image… menu command. You can display the image using any band combination that you wish.

8.2
Use the File–>Open Image… menu command to open a shape file such as Area_Agricola_AQP.shp in the Remote Sensing Workshop folder.  You may need to change the filter (Files of types) in the open image dialog box to ‘Shape’ or ‘All’.  The shape file will be overlaid onto the image window as illustrated above with black lines.



MultiSpec will automatically convert lat-long shape files to respective map coordinates for images in Albers Conical Equal Area, Cylindrical Equal Area, Equirectangular, Krovak, Lambert Azimuthal Equal Area, Lambert Conformal Conic, Orthographic, Polar Stereographic, Sinusoidal & Transverse Mercator map projections and State Plane, UTM and several other reference systems. MultiSpec first assumes the shape file is in the same units as the map projection. If there is no overlap, MultiSpec checks if the input shape file units are within the range possible for decimal latitude-longitude degrees. If so, MultiSpec assumes the shape file is in lat-long units and converts them to map projection units. If the converted shape file values overlap with the image, then the shape file is overlaid onto the image. If a shape file has been converted, _ltom is appended to the shape file name in the overlay list for the window. (Comment: ltom stands for lat-long to meters.)

8.3
One can obtain a dialog box for editing the vector line width and color in the Windows version by holding the shift key down before selecting the Overlay menu button with the left mouse button and then select the shape file overlay to be edited.  Note that … now follows the overlay name indicating that a dialog box will be displayed.  One can obtain this dialog box in the Macintosh version by holding the Option key down and selecting the Overlay menu button and then selecting the overlay to be edited.
Change the color of the shape files lines that have been drawn to white with a thickness of 2.

8.4
Notes:

- One can use the Edit->Clear Overlay menu item to remove the selected shape file from memory.  The list of shape files in this list will include all shape files drawn in all open image windows.  If one also has an image in geometric (lat-long) projection, shape files on these images will be treated as a separate shape files in the Edit–>Clear Overlay list

- MultiSpec will draw shape files correctly on images that have a map rotation angle such as the level 1B Aster data.

( Exercise 9:  Creating Vegetation Index (NDVI) Images.

Requirements:  MultiSpec application and S2B_20180515_10m_4bands_majes_area.tif.
One can create images that represent algebraic combinations of the original channels of an image to try to enhance the image. This technique is used to enhance the vegetation or mineral variations in the image. One example is the Normalized Vegetation Index (NDVI) image. These images represent an algebraic combination of the red and near infrared bands to represent the amount of green vegetation in the image.

The formula is:

                  NIR - Red

NDVI =    --------------

                  NIR + Red

Where NIR represents the Near Infrared channel or band and Red represents the red channel or band. This formula results in a value that nominally varies between -1 (usually water) to +1 (strongest vegetation growth).

To start this exercise, be sure that the “S2B_20180515_10m_4bands_majes_area.tif” image that was used in exercise 1 is open and represents the top-most image window in MultiSpec. Also clear any selections in the image window by striking the “Delete Key”

9.1
From the Processor menu, select Reformat->Change Image File Format… to bring up the Image File Format Change Options dialog box. 
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9.2
Select the “Transform Data…” checkbox. This will cause the “Set Reformat Transform Parameters” dialog box to be displayed.
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9.3
Then select “New Channel from General Algebraic Transformation” This will cause the window below to be displayed.
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The editable boxes in the above window allow one to define an algebraic combination of the original input channels to create a new channel such as NDVI. The transformation is in the form of = offset + (a0 + a1C1 + a2C2 + ...)/(b0 + b1C1 + b2C2 + ...) * factor; where offset, factor, a0, a1, b0, b1, ... are real constants which can be positive or negative and C1, C2, ...Cn represent the channel number to be used. Both 'c' or 'C' can be used. The number of constant*Channel value (e.g. a1C1) combinations in either the numerator or the denominator is limited to the number of channels in the active image file plus 1. Also the number of characters in the numerator and denominator is limited to 255. Note that one can create only one new channel at a time.

9.4
This tutorial is based on the S2B_20180515_10m_4bands_majes_area.tif image file in which the red band is channel 3 and the near-infrared band is channel 4. Therefore to create a NDVI image for this image as defined in the introduction for this tutorial the equation (algebraic combination) will look like:



1.0C4 – 1.0C3
NDVI  =  0  +  ------------------- * 1



1.0C3 + 1.0C4
These happen to be the default values provided in the New Channel from General Algebraic Transformation in the window displayed above. 
Since the real constants a1, a2, b1, b2 are 1.0, one can also enter the transformation as illustrated by the dialog box below.
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Then select OK to accept the defined algebraic transformation. This will close the “Set Reformat Transform Parameters dialog box and bring the “Image File Format Change Options” dialog box back to the top.

9.5
In the “Image File Format Change Options” dialog box, select “32-bit Real” in the Data value type popup menu.
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Note that requesting the output data values to be real numbers is important since the resulting data values nominally range between -1 and +1. 

If the output data values are converted to signed integer values, one will end up with only -1’s, 0’s, or 1’s or if to unsigned integer values, one will end up with only 0’s and 1’s.

9.6
Select OK to close this dialog box and start the processing to create the NDVI image file. The “Save New Image File As” dialog box will now appear, as given below, to allow one to enter the desired file name. Then select “Save”. The new NDVI image file will be written to the disk at the requested location.
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Check the log output in the text window for this operation to verify that the creation of the NDVI image went well. The log output should be similar to the following:

Reformat: Change Image File Format  07-16-2018  15:22:52 (MultiSpecWin64_2018.07.16)

  Input Parameters:

    Image file = 'S2B_20180515_10m_4bands_majes_area.tif'

    Create transformed channel image

    = 0.000000 + (C4-C3)/(C3+C4) * 1.000000

     Lines 1 to 625 by 1.  Columns 1 to 800 by 1

    Channels used: 

        3: 0.646-0.685 um  

        4: 0.767-0.900 um  

  Output Information:

    New output image file name: 'S2B_20180515_10m_4bands_majes_area_ndvi.tif'

    File format:              GeoTIFF

    Image type:               Multispectral

    Instrument Name:          Sentinel-2B MSI

    Band interleave format:   BSQ

    Data type:                Real

    Swap bytes:               No

    Signed data:              Yes

    Number of lines:                     625

    Number of columns:                   800

    Number of channels:                    1

    Number of bytes:                       4

    Number of bits:                       32

    Number of header bytes:              502

    Number of pre-line bytes:              0

    Number of post-line bytes:             0

    Number of pre-channel bytes:           0

    Number of post-channel bytes:          0

    Line start:                            1

    Column start:                          1

    -0.419066 is lowest calculated value

    0.833827 is highest calculated value

    0 data values saturated at low end: -3.40282e+38

    0 data values saturated at high end: 3.40282e+38

  0 CPU seconds for reformatting.  07-16-2018  15:25:40
One should verify that the transformation equation used is as you expected. One should also check the lowest and highest calculated value to verify that these values make sense. One should also verify that the number of pixels saturated at the low and high ends are 0 or at least a very small portion of the total number of data values in the image.

NOTE: 
A large number of saturated data values may indicate that the data output type needs to be changed from integer to real. A very small range in data from the lowest to highest data value may also indicate that one needs to change the data type from integer to real or one needs to provide scaling and offset values to adjust the range of the output data values for better precision. 

For example if one used 8-bit unsigned integer as the data type to create an NDVI image from S2B_20180515_10m_4bands_majes_area.tif, the NDVI image will have over 300,000 ‘0’ data values and 180,000 ‘1’ data values. This image will not be very useful. However if one changes the gain value in the transformation from 1 to 100 and uses 8-bit signed integer, one will end up with a data range of -42 to 83. The variation in the NDVI values are spread across a good portion of the entire range possible for an 8-bit signed integer data value. One will just need to keep in mind that an image value of 100 represents an actual NDVI value of 1.

9.7
One can now display the resulting image as either a 1-channel gray scale type image or as a 1-channel thematic type as show below. See Exercise 1 for steps to do this if needed.
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1-channel type display of the resulting NDVI image. High NDVI values which represent significant amounts of green vegetation are illustrated by light tones. Bare soil is represented by darker tones.
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1-channel thematic display of the resulting NDVI image using the MODIS NDVI palette. The min-max enhancement values were set to 0 and 1. The legend on the left relate the color tones with the NDVI values.
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( Exercise 10:  Image Enhancement

Requirements:  MultiSpec application and image titled “and S2B_20180515_10m_4bands_majes_area.tif”.
Open the image if it is not already displayed in a multispectral image window following the guidelines given in exercise 1 (Display and Inspection of Image Data with MultiSpec). 

One can control the enhancement of the image in the multispectral image window by setting five different options in the Enhancement portion of the Display Specifications dialog box including Bits of color, Stretch, Min-maxes, Treat ‘0’ as and Display levels per channel. 
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10.1
The “Bits of color” default is 24 and the “Display levels per channel” default is 256 for all monitors now days for the maximum number of colors possible.  One can adjust to lower values if one wishes to see what the affects are.
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The figure above illustrates 256 display levels per channel (millions of colors) on the left and 2 display levels per channel (8 colors) on the right.

10.2
The Treat ‘0’ as data setting causes 0 values to be displayed as black. However, if 0’s actually represent background or ‘no data’, one may want to select the background option to cause 0’s in all channels to be displayed as white. The figure below illustrates 0’s treated as black on the left and 0’s as white on the right.
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The image being used for these exercises does not have a block of 0 values to illustrate this feature.
10.3
The Stretch and Min-maxes are usually the options used to enhance different parts of the image. They control the process by which each possible data value in the image data is assigned to all possible display levels. 


There are three choices for Stretch:  Linear, Equal Area and Gaussian. In the case of Linear Stretch, gray scale intervals are equally spaced over the data range, while the Equal Area Stretch choice causes them to be set so that each interval represents about the same number of pixels. Though nonlinear, the equal area stretch will provide maximum contrast.  The Gaussian selection causes the distribution of the number of pixels assigned to the gray scale intervals to represent a Gaussian curve. If one holds the 'Option' key down (Mac version) or the 'Right Mouse button down (Windows version) before you select the enhancement Stretch popup menu with the left button, you can change the number of standard deviations that the data will be fit to for the Gaussian selection. The default is 2.3.
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Linear, equal area and Gaussian stretches are illustrated in figure above left to right.

10.4
The Min-maxes option allows one to select the beginning and end data values of the image histogram to be used for assigning the pixels in the gray scale intervals defined by the Stretch option. The “Entire Range” choice for this option would cause lowest data value possible in the image, 0 for 16-bit unsigned data, to be the first data value displayed for lowest display value (black) and 65,535 to be the last data value displayed for the highest display value (white).  However for a linear stretch, if the actual range of the data is only 400 to 8000, then the data will only be represented by grays not black to white; there will not be much contrast in the image. The image could even be all black if all data values are near the beginning of the range or all white if near the end of the possible 16-bit range.

The “Clip 2 % of Tails” choice will cause the selected begin and end range of data values for a given channel to represent those data values in which 2 percent of them in the histogram are outside of the selected range.  The intent of this choice is to reduce the chance that a small number of extreme outlier data values in the image will unduly influence the display enhancement. This choice usually results in a display of the data that has better contrast over all. 


Selection of the Specify Min-Max... choice presents a dialog box (illustrated below) to allow one to set percent of tails clipped to be something other than 2%.  You can also set your own min-max values to stretch the gray levels across.  The actual data min and max values computed from the histogram are included in the dialog box.
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0% clip, 2% clip and 10% clip is illustrated below from left to right.
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The entire range for a min-max setting for this 16-bit data set will result in a black image.
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